Saturday, May 13, 2017

Mikrotik MPLS L2





Mikrotik MPLS L2






 


 



Dhanmondi PE Router

/ip address
add address=72.156.28.6/30 interface=ether3 network=72.156.28.4
add address=72.156.28.2/30 interface=ether1 network=72.156.28.0
add address=72.156.28.152 interface=LB network=72.156.28.152

/interface bridge add comment="MPLS Loopback" name="MPLS Loopback"
 
/routing ospf instance set [ find default=yes ] router-id=72.156.28.152
 
/routing ospf network
add area=backbone network=72.156.28.0/30
add area=backbone network=72.156.28.4/30
add area=backbone network=72.156.28.152/32
 
/mpls interface
set [ find default=yes ] interface=ether1
add interface=ether3
 
/mpls ldp set enabled=yes lsr-id=72.156.28.152 transport-address=72.156.28.152
 
/mpls ldp interface
add interface=ether1
add interface=ether3
 
/mpls ldp neighbor
add transport=72.156.28.150
add transport=72.156.28.151



Gulshan PE Router

/ip address
add address=72.56.30.2/24 interface=ether1 network=72.56.30.0
add address=72.156.28.9/30 interface=ether2 network=72.156.28.8
add address=72.156.28.5/30 interface=ether3 network=72.156.28.4
add address=72.156.28.151 interface=LB network=72.156.28.151

/interface bridge add comment="MPLS Loopback" name="MPLS Loopback"
 
/routing ospf instance set [ find default=yes ] router-id=72.156.28.151
 
/routing ospf network
add area=backbone network=72.156.28.8/30
add area=backbone network=72.156.28.4/30
add area=backbone network=72.156.30.0/24
add area=backbone network=72.156.28.151/32
 
/mpls interface
set [ find default=yes ] interface=ether2
add interface=ether3
add interface=ether1
 
/mpls ldp set enabled=yes lsr-id=72.156.28.151 transport-address=72.156.28.151
 
/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3
 
/mpls ldp neighbor
add transport=72.156.28.150
add transport=72.156.28.152
add transport=72.156.30.120





BANANI PE Router

/ip address
add address=72.156.28.10/30 interface=ether2 network=72.156.28.8
add address=75.156.29.1/24 interface=ether3 network=75.156.29.0
add address=72.156.28.150 interface=LB network=72.156.28.150
add address=72.156.28.1/30 interface=ether1 network=72.156.28.0

/interface bridge add comment="MPLS Loopback" name="MPLS Loopback"
 
 /routing ospf instance set [ find default=yes ] router-id=72.156.28.150
 
/routing ospf network
add area=backbone network=72.156.28.0/30
add area=backbone network=72.156.28.8/30
add area=backbone network=72.156.28.150/32
add area=backbone network=72.156.29.0/24
 
 /mpls interface
set [ find default=yes ] interface=ether1 
add interface=ether2
add interface=ether3
 
/mpls ldp set enabled=yes lsr-id=72.156.28.150 transport-address=72.156.28.150
 
/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3
 
/mpls ldp neighbor
add transport=72.156.28.151
add transport=72.156.28.152
add transport=72.156.29.120





At this point we have OSPF running in the core, and MPLS running as well on the LSR routers. From this point on we'll focus on the LERs that actually connect to the customers. We'll add an additional bridge for VPLS traffic, configure OSPF and MPLS with LDP on each of the LERs, then we'll move on to building the VPLS tunnels.

BANANI DOHS CE Router

/ip address
add address=75.156.29.3/24 interface=ether1 network=75.156.29.0
add address=72.156.29.120 interface=LB network=72.156.29.120

/interface bridge
add comment="MPLS Loopback" name="MPLS Loopback"
add comment="Customer #4306 Site 1" name="VPLS Customer 4306-1 Bridge"

/routing ospf instance set [ find default=yes ] router-id=72.156.29.120

/routing ospf network
add area=backbone network=72.156.29.0/24
add area=backbone network=72.156.29.120/32

/mpls interface set [ find default=yes ] interface=ether3

/mpls ldp set enabled=yes lsr-id=72.156.29.120 transport-address=72.156.29.120

/mpls ldp interface add interface=ether3

/mpls ldp neighbor add transport=72.156.28.150


GULSHAN 1 CE Router

/ip address
add address=10.10.10.1/24 interface="VPLS Customer 4306-1 Bridge" network=10.10.10.0
add address=72.56.30.1/24 interface=ether4-slave-local network=72.56.30.0
add address=72.156.30.120/32 interface=LB network=72.156.30.120

/interface bridge
add comment="MPLS Loopback" name="MPLS Loopback"
add comment="Customer #4306 Site 2" name="VPLS Customer 4306-2 Bridge"
 
/routing ospf instance set [ find default=yes ] router-id=72.156.30.120
 
/routing ospf network
add area=backbone network=72.156.30.0/24
add area=backbone network=72.156.30.120/32
 
/mpls interface set [ find default=yes ] interface=ether1
 
/mpls ldp set enabled=yes lsr-id=72.156.30.120 transport-address=72.156.30.120
 
/mpls ldp interface add interface=ether1
/mpls ldp neighbor add transport=72.156.28.151
 
 
This is MPLS at work, associating routes with labels for quick lookup, which is what gives MPLS its trademark performance boost over regular end-to-end IP routing. We're ready now to add the VPLS tunnels and start moving some traffic transparently between sites. The extra bridge interfaces that we added on the two LERs will be used to bridge the VPLS virtual interfaces with physical Ethernet interfaces that we hand off to the customer.

BANANI DOHS CE Router
 
/interface vpls
add comment="Customer 4306-2 VPLS" disabled=no l2mtu=1500 name="Customer 4306-2 VPLS" remote-peer=72.156.30.120 vpls-id=90:0
 
/interface bridge port
add bridge="VPLS Customer 4306-1 Bridge" interface=ether1
add bridge="VPLS Customer 4306-1 Bridge" interface="Customer 4306-2 VPLS"


GULSHAN 1 CE Router

/interface vpls
add comment="Customer 4306-1 VPLS" disabled=no l2mtu=1500 name="Customer 4306-1 VPLS" remote-peer=72.156.29.120 vpls-id=90:0

/interface bridge port
add bridge="VPLS Customer 4306-2 Bridge" interface=ether3
add bridge="VPLS Customer 4306-2 Bridge" interface="Customer 4306-1 VPLS"